Showing results for 
Search instead for 
Did you mean: 
SAP Community Log-in Update
In a few months, SAP Community will switch to SAP Universal ID as the only option to login. Don’t wait, create your SAP Universal ID now! If you have multiple S- or P- accounts, use the Consolidation Tool to merge your content. Get started with SAP Universal ID now!

Questions re: "Open-Source ABAP" Developer Challenge


This discussion thread is to ask your questions and discuss issues, if participating in the May 2023 Developer Challenge - Open-Source ABAP

Please use separate discussions created for the submission of your solutions. Keep this thread for your questions only.



Hello Mamikee, I am receiving this error when I try to open ABAPGit repositories from Eclipse.

ADT Link.

2023-05-13 13_11_48-Greenshot.png

Any idea?


Thank you.

Best regards,


make sure to update to latest, had a syntax error fixed few weeks ago, 


No luck, I still get the same error.

I have attached the screenshot of the error log (part of it at least ).2023-05-27 14_05_40-Greenshot.png2023-05-27 14_07_48-Greenshot.png













Stellar 2
Stellar 2

How to code in Eclipse for ABAP. I was using Temporary Login Credentials in my training. As I used to code 

there, I'm confused about how to do it over here, someone guide me.



Vinod. K





Galactic 3
Galactic 3

Hi Mamikee,


I m getting below for pushing changes to Git repository.

I have even tried giving personal access token still same error.



Please help.


Thanks and Regards,

Gaurav Phadnis

Galactic 2
Galactic 2

Hi guys ,

I used the _bind method , but can't able to fetch the data from frontend to backend .Please anyone suggest the way to pick the data from frontend.

Please find the code 


Thanks in advance.


Is the issue just with the "user" field or with "date" as well? You need to use the _bind action for "user" as well. I assume the date should be working fine.

client->_bind( user )

Galactic 2
Galactic 2

Hello everyone!

I'm having a problem running the second challenge. I will give an overview of my situation so that it is easier to understand.

In my SAP environment it was not possible to perform the online pull or push request to the GitHub repository, so I had to do this installation process manually and I was able to install abap2ui5, I created the class responsible for the handle request, I also created the http service with the class responsible for the handle request, but when testing the service, the page informs me that it was not possible to find the IP address of the server.

My question is the following, would this be a configuration error that I made or would it be due to the fact that I did not have access, as was the case of not being able to make a pull or push request from the github repository?