SAP SuccessFactors Learning Life Sciences User Group Discussions
cancel
Showing results forΒ 
Search instead forΒ 
Did you mean:Β 

User Connector - SF Issue

ward_scott
Galactic 6
Galactic 6
0 Kudos

Is anyone else having issues with their User Connector? The last working update we had was last Saturday and, while Support is investigating, we are on day 5 now  and this is becoming a serious business issue.

Our process for uploading content using User Connector - SF has been automated for years and nothing changed on our end. I have inquired if this had anything to do with the HXM update Saturday night but they are going through the process. 

Thanks,

Ward

2 ACCEPTED SOLUTIONS

ward_scott
Galactic 6
Galactic 6
0 Kudos

It took a week but the issue was on our side. One upload failed and everything thereafter stacked up like a printer queue after a document failed to print. It was pretty easy for SAP to diagnose once we got connected to the right person.

ward_scott
Galactic 6
Galactic 6
0 Kudos

The file is created by an API our IT group created years ago. It was a one-off event, unlikely to ever occur again. Still, it is on our resolution list so we can check for that issue if we ever have problems in the future.

18 REPLIES 18

MarcusKnappe
Galactic 4
Galactic 4
0 Kudos

Hi Ward,
we have no issues or problems with this connector (DC12).

We use the people profile export via provisioning (standard) and add additional fields via Integration Center (user_extended_data.txt).

Hope your issue is resolved soon πŸ™‚

Marcus

ward_scott
Galactic 6
Galactic 6
0 Kudos

That's good news. I would rather this be an isolated incident than an issue with the system. It's just so odd that a system that has not changed is suddenly broken. 

Ibrosseau
Galactic 3
Galactic 3
0 Kudos

Just in case this help, are you award of the following:

"As a follow up to previous communications, please note as part of SuccessFactors’ continuous effort of improving product security, SAP SuccessFactors will disable support for diffie-hellman-group-exchange-sha1 on our SFTP servers in Production and Non-Production environments starting on January 15, 2022."

Brabham_Marla
Galactic 4
Galactic 4
0 Kudos

We are not having any issues.

Marla

Param_SFSF
Galactic 3
Galactic 3
0 Kudos

Thanks for bringing up the issue.

Can you please provide more details on the issue? 

BR,

Param

ward_scott
Galactic 6
Galactic 6
0 Kudos

It took a week but the issue was on our side. One upload failed and everything thereafter stacked up like a printer queue after a document failed to print. It was pretty easy for SAP to diagnose once we got connected to the right person.

PKetnouvong
Galactic 4
Galactic 4
0 Kudos

I would check the actual txt file.  Is your text file coded in UTF or ANSI?  That might be the issue.  

ward_scott
Galactic 6
Galactic 6
0 Kudos

The file is created by an API our IT group created years ago. It was a one-off event, unlikely to ever occur again. Still, it is on our resolution list so we can check for that issue if we ever have problems in the future.

RichardEason
Galactic 3
Galactic 3
0 Kudos

Ward,

We are having this same issue with out SF User Connector since last Friday. Do you know if SF reset the queue or was there something you did to resolve the issue.

Richard

0 Kudos

We have one IT LAN manager responsible for LMS. he was able to resolve it on our end.

Ikram
Galactic 3
Galactic 3
0 Kudos

Yes Sir. The SF User connector are not fetching the files from the FTP server. It started today at 9am EST. 

LMS1
Galactic 3
Galactic 3
0 Kudos

We have been facing same issue since yesterday. Do anyone know how to resolved it? 

shreetamamand
Galactic 3
Galactic 3
0 Kudos

Currently we are facing issue only in DC2 system.

Thanks,

Shreetama

Ikram
Galactic 3
Galactic 3
0 Kudos

Nothing we can do as a customer. The issue is picking up the files from SF FTP server. Never saw that, I couldn't connect to FTP server. Even if I do, I couldn't fine the folder structure. 

The last I heard from SAP Support is "reported scenario is still being verified internally by SAP Operations team and we are monitoring the process to keep you posted on this incident."

MarcusKnappe
Galactic 4
Galactic 4
0 Kudos

For us in DC12 it is still working. Are also other connectors (class, item, curriculum etc.) issued?

What happens when you click on "Test FTP connection" in the connector?

0 Kudos

Item connector was also not working, as we send files from Document Management System to to SF FTP server. 

The latest I heard from SAP Support "As per the investigation from Engineering team the issue is due to obsolete data in the backend and the same needs to be deleted via scripts to fix the issue."

Before I give blanket approval, I need to know what is obsolete data in the backend?

ward_scott
Galactic 6
Galactic 6
0 Kudos

Are they suggesting that this is something on your side? If so, it sounds like a similar issue to our issue with the user upload where one upload failed, "blocked" the works and prevented any future updates from working.

I would think that your IT team can see where on the SFTP site the uploads are directed but our user upload hits two folders:

  • FEED/UPLOAD
  • /incoming

0 Kudos

Not on our side. It is a global issue. SAP Operations team are investigating this issue on the SFTP in the back end.